EditorsKit < 1.31.6 - Contributor+ Arbitrary PHP Code Execution
Priority MEDIUM 42CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-94.
Summary
The Gutenberg Block Editor Toolkit – EditorsKit WordPress plugin before 1.31.6 does not sanitise and validate the Conditional Logic of the Custom Visibility settings, allowing users with a role as low contributor to execute Arbitrary PHP code
Why it matters now
EPSS 0.01811 78th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Gutenberg Block Editor Toolkit – EditorsKit (Unknown): 1.31.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Gutenberg Block Editor Toolkit – EditorsKit | 1.31.6 to before 1.31.6 | 1.31.6 | Patch available | CNA |
- Gutenberg Block Editor Toolkit – EditorsKit VendorUnknown Affected 1.31.6 to before 1.31.6 Fixed in 1.31.6 Patch available CNA
Remediation
- Fix · CNA Gutenberg Block Editor Toolkit – EditorsKit (Unknown) Fixed in 1.31.6
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24546
- 2026-10-03 Alias added: GHSA-69mw-rrjx-rv39
References
More extendify Editorskit vulnerabilities
- TI-2023-06081 EditorsKit <= 1.40.3 - Authenticated (Administrator+) Arbitrary File Upload CVSS 3.1HIGH 7.2
Sources
- CVE-2021-24546 · CVE Program
- CVE-2021-24546 · NVD
- FIRST EPSS
- GHSA-69mw-rrjx-rv39 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences