Read the docs
TI-2021-06844 Aliases CVE-2021-24559GHSA-833g-hhhp-wggv

Qyrr < 0.7 - Authenticated (contributor+) Stored XSS

Priority LOW 24CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Qyrr WordPress plugin before 0.7 does not escape the data-uri of the QR Code when outputting it in a src attribute, allowing for Cross-Site Scripting attacks. Furthermore, the data_uri_to_meta AJAX action, available to all authenticated users, only had a CSRF check in place, with the nonce available to users with a role as low as Contributor allowing any user with such role (and above) to set a malicious data-uri in arbitrary QR Code posts, leading to a Stored Cross-Site Scripting issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00218 12th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Qyrr (Unknown): 0.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownQyrrbefore 0.70.7Patch availableCNA
  • Qyrr VendorUnknown Affected before 0.7 Fixed in 0.7 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:patrickposner:qyrr:*:*:*:*:*:wordpress:*:*before 0.7Vulnerablepatrickposner
  • cpe:2.3:a:patrickposner:qyrr:*:*:*:*:*:wordpress:*:* Versions before 0.7 Vulnerable ·patrickposner

Remediation

  • Fix · CNA Qyrr (Unknown) Fixed in 0.7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24559
  2. 2026-10-03 Alias added: GHSA-833g-hhhp-wggv

References

Sources