Cookie Notice & Compliance for GDPR / CCPA < 2.1.2 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Cookie Notice & Compliance for GDPR / CCPA WordPress plugin before 2.1.2 does not escape the value of its Button Text setting when outputting it in an attribute in the frontend, allowing high privilege users such as admin to perform Cross-Site Scripting even when the unfiltered_html capability is disallowed.
Why it matters now
EPSS 0.00617 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Cookie Notice & Compliance for GDPR / CCPA (Unknown): 2.1.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Cookie Notice & Compliance for GDPR / CCPA | 2.1.2 to before 2.1.2 | 2.1.2 | Patch available | CNA |
- Cookie Notice & Compliance for GDPR / CCPA VendorUnknown Affected 2.1.2 to before 2.1.2 Fixed in 2.1.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hu-manity:cookie_notice_\&_compliance_for_gdpr_\/_ccpa:*:*:*:*:*:wordpress:*:* | before 2.1.2 | Vulnerable | Hu-manity.co |
- cpe:2.3:a:hu-manity:cookie_notice_\&_compliance_for_gdpr_\/_ccpa:*:*:*:*:*:wordpress:*:* Versions before 2.1.2 Vulnerable ·Hu-manity.co
Remediation
- Fix · CNA Cookie Notice & Compliance for GDPR / CCPA (Unknown) Fixed in 2.1.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24569
- 2026-10-03 Alias added: GHSA-w27v-jm67-3gjf
References
More Hu-manity.co Cookie Notice & Compliance For Gdpr / Ccpa vulnerabilities
- TI-2023-00781 Cookie Notice & Compliance for GDPR / CCPA < 2.4.7 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2023-10022 WordPress Cookie Notice & Compliance for GDPR / CCPA Plugin <= 2.4.6 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-24569 · CVE Program
- CVE-2021-24569 · NVD
- FIRST EPSS
- GHSA-w27v-jm67-3gjf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences