Read the docs
TI-2021-06856 Aliases CVE-2021-24571GHSA-7hqj-44cw-26jp

HD Quiz < 1.8.4 - Authenticated Stored XSS

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The HD Quiz WordPress plugin before 1.8.4 does not escape some of its Answers before outputting them in attribute when generating the Quiz, which could lead to Stored Cross-Site Scripting issues

Why it matters now

EPSS 0.00624 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed HD Quiz (Unknown): 1.8.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownHD Quiz1.8.4 to before 1.8.41.8.4Patch availableCNA
  • HD Quiz VendorUnknown Affected 1.8.4 to before 1.8.4 Fixed in 1.8.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:harmonicdesign:hd_quiz:*:*:*:*:*:wordpress:*:*before 1.8.4VulnerableHarmonic Design
  • cpe:2.3:a:harmonicdesign:hd_quiz:*:*:*:*:*:wordpress:*:* Versions before 1.8.4 Vulnerable ·Harmonic Design

Remediation

  • Fix · CNA HD Quiz (Unknown) Fixed in 1.8.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24571
  2. 2026-10-03 Alias added: GHSA-7hqj-44cw-26jp
  3. 2026-11-04 EPSS moved to the 50th–90th percentile

References

  • TI-2024-12425 HD Quiz < 2.0.0 - Editor+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2024-14762 WordPress HD Quiz Plugin <= 1.8.11 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9

Sources