Highlight < 0.9.3 - Authenticated Stored Cross-Site Scripting
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Highlight WordPress plugin before 0.9.3 does not sanitise its CustomCSS setting, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Why it matters now
EPSS 0.00624 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Highlight (Unknown): 0.9.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Highlight | 0.9.3 to before 0.9.3 | 0.9.3 | Patch available | CNA |
- Highlight VendorUnknown Affected 0.9.3 to before 0.9.3 Fixed in 0.9.3 Patch available CNA
Remediation
- Fix · CNA Highlight (Unknown) Fixed in 0.9.3
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24591
- 2026-10-03 Alias added: GHSA-c3m7-gw6j-3wx2
- 2026-11-04 EPSS moved to the 50th–90th percentile
References
Sources
- CVE-2021-24591 · CVE Program
- CVE-2021-24591 · NVD
- FIRST EPSS
- GHSA-c3m7-gw6j-3wx2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences