Sitewide Notice WP < 2.3 - Authenticated Stored XSS
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Sitewide Notice WP WordPress plugin before 2.3 does not sanitise some of its settings before outputting them in frontend pages, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Why it matters now
EPSS 0.00617 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Sitewide Notice WP (Unknown): 2.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Sitewide Notice WP | 2.3 to before 2.3 | 2.3 | Patch available | CNA |
- Sitewide Notice WP VendorUnknown Affected 2.3 to before 2.3 Fixed in 2.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yoohooplugins:sitewide_notice:*:*:*:*:*:wordpress:*:* | before 2.3 | Vulnerable | Yoohoo Plugins |
- cpe:2.3:a:yoohooplugins:sitewide_notice:*:*:*:*:*:wordpress:*:* Versions before 2.3 Vulnerable ·Yoohoo Plugins
Remediation
- Fix · CNA Sitewide Notice WP (Unknown) Fixed in 2.3
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24592
- 2026-10-03 Alias added: GHSA-w8mm-7prp-fr25
References
Sources
- CVE-2021-24592 · CVE Program
- CVE-2021-24592 · NVD
- FIRST EPSS
- GHSA-w8mm-7prp-fr25 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences