Read the docs
TI-2021-06919 Aliases CVE-2021-24636GHSA-587q-w3p6-m55g

Print My Blog < 3.4.2 - Plugin Deactivation via CSRF

Priority LOW 36CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.

Summary

The Print My Blog WordPress Plugin before 3.4.2 does not enforce nonce (CSRF) checks, which allows attackers to make logged in administrators deactivate the Print My Blog plugin and delete all saved data for that plugin by tricking them to open a malicious link

Why it matters now

EPSS 0.00537 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Print My Blog – Print, PDF, & eBook Converter WordPress Plugin (Unknown): 3.4.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPrint My Blog – Print, PDF, & eBook Converter WordPress Plugin3.4.2 to before 3.4.23.4.2Patch availableCNA
  • Print My Blog – Print, PDF, & eBook Converter WordPress Plugin VendorUnknown Affected 3.4.2 to before 3.4.2 Fixed in 3.4.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:print_my_blog_project:print_my_blog:*:*:*:*:*:wordpress:*:*before 3.4.2VulnerablePrint My Blog Project
  • cpe:2.3:a:print_my_blog_project:print_my_blog:*:*:*:*:*:wordpress:*:* Versions before 3.4.2 Vulnerable ·Print My Blog Project

Remediation

  • Fix · CNA Print My Blog – Print, PDF, & eBook Converter WordPress Plugin (Unknown) Fixed in 3.4.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24636
  2. 2026-10-03 Alias added: GHSA-587q-w3p6-m55g

References

  • TI-2019-08644 Server Side Request Forgery (SSRF) exists in the Print My Blog plugin before 1.6.7 for WordPress via the site parameter. CVSS 3.0CRITICAL 9.8
  • TI-2024-24786 WordPress Print My Blog plugin <= 3.27.0 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.9

Sources