Fonts Plugin < 3.0.3 - Contributor+ Stored Cross-Site Scripting
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Google Fonts Typography WordPress plugin before 3.0.3 does not escape and sanitise some of its block settings, allowing users with as role as low as Contributor to perform Stored Cross-Site Scripting attacks via blockType (combined with content), align, color, variant and fontID argument of a Gutenberg block.
Why it matters now
EPSS 0.00624 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Fonts Plugin | Google Fonts Typography (Unknown): 3.0.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Fonts Plugin | Google Fonts Typography | 3.0.3 to before 3.0.3 | 3.0.3 | Patch available | CNA |
- Fonts Plugin | Google Fonts Typography VendorUnknown Affected 3.0.3 to before 3.0.3 Fixed in 3.0.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fontsplugin:fonts:*:*:*:*:*:wordpress:*:* | before 3.0.3 | Vulnerable | Fonts Plugin |
- cpe:2.3:a:fontsplugin:fonts:*:*:*:*:*:wordpress:*:* Versions before 3.0.3 Vulnerable ·Fonts Plugin
Remediation
- Fix · CNA Fonts Plugin | Google Fonts Typography (Unknown) Fixed in 3.0.3
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24637
- 2026-10-03 Alias added: GHSA-x8c7-9c7c-54qw
- 2026-11-04 EPSS moved to the 50th–90th percentile
References
More Fonts Plugin Fonts vulnerabilities
- TI-2024-28954 WordPress Fonts plugin <= 3.7.7 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2024-28953 WordPress Fonts plugin <= 3.7.7 - Cross Site Request Forgery (CSRF) to Stored XSSvulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2021-24637 · CVE Program
- CVE-2021-24637 · NVD
- FIRST EPSS
- GHSA-x8c7-9c7c-54qw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences