Cookie Bar < 1.8.9 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Cookie Bar WordPress plugin before 1.8.9 doesn't properly sanitise the Cookie Bar Message setting, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Why it matters now
EPSS 0.00617 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Cookie Bar (Unknown): 1.8.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Cookie Bar | 1.8.9 to before 1.8.9 | 1.8.9 | Patch available | CNA |
- Cookie Bar VendorUnknown Affected 1.8.9 to before 1.8.9 Fixed in 1.8.9 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cookie-bar_project:cookie-bar:*:*:*:*:*:wordpress:*:* | before 1.8.9 | Vulnerable | Cookie-bar Project |
- cpe:2.3:a:cookie-bar_project:cookie-bar:*:*:*:*:*:wordpress:*:* Versions before 1.8.9 Vulnerable ·Cookie-bar Project
Remediation
- Fix · CNA Cookie Bar (Unknown) Fixed in 1.8.9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24653
- 2026-10-03 Alias added: GHSA-p78v-gqwj-9c32
References
Sources
- CVE-2021-24653 · CVE Program
- CVE-2021-24653 · NVD
- FIRST EPSS
- GHSA-p78v-gqwj-9c32 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences