PDF Light Viewer < 1.4.12 - Authenticated Command Injection
Priority MEDIUM 45CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-78.
Summary
The WordPress PDF Light Viewer Plugin WordPress plugin before 1.4.12 allows users with Author roles to execute arbitrary OS command on the server via OS Command Injection when invoking Ghostscript.
Why it matters now
EPSS 0.04267 91st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WordPress PDF Light Viewer Plugin (Unknown): 1.4.12
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WordPress PDF Light Viewer Plugin | 1.4.12 to before 1.4.12 | 1.4.12 | Patch available | CNA |
- WordPress PDF Light Viewer Plugin VendorUnknown Affected 1.4.12 to before 1.4.12 Fixed in 1.4.12 Patch available CNA
Remediation
- Fix · CNA WordPress PDF Light Viewer Plugin (Unknown) Fixed in 1.4.12
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24684
- 2026-10-03 Alias added: GHSA-25m3-pw7x-34hv
References
Sources
- CVE-2021-24684 · CVE Program
- CVE-2021-24684 · NVD
- FIRST EPSS
- GHSA-25m3-pw7x-34hv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences