Read the docs
TI-2021-06999 Aliases CVE-2021-24717GHSA-w87w-64p4-f94p

AutomatorWP < 1.7.6 - Missing Authorization and Privilege Escalation

Priority MEDIUM 41CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-863.

Summary

The AutomatorWP WordPress plugin before 1.7.6 does not perform capability checks which allows users with Subscriber roles to enumerate automations, disclose title of private posts or user emails, call functions, or perform privilege escalation via Ajax actions.

Why it matters now

EPSS 0.01337 71st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed AutomatorWP (Unknown): 1.7.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownAutomatorWP1.7.6 to before 1.7.61.7.6Patch availableCNA
  • AutomatorWP VendorUnknown Affected 1.7.6 to before 1.7.6 Fixed in 1.7.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:automatorwp:automatorwp:*:*:*:*:*:wordpress:*:*before 1.7.6VulnerableAutomatorWP
  • cpe:2.3:a:automatorwp:automatorwp:*:*:*:*:*:wordpress:*:* Versions before 1.7.6 Vulnerable ·AutomatorWP

Remediation

  • Fix · CNA AutomatorWP (Unknown) Fixed in 1.7.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24717
  2. 2026-10-03 Alias added: GHSA-w87w-64p4-f94p

References

  • TI-2023-09779 WordPress AutomatorWP Plugin <= 2.5.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1MEDIUM 5.4

Sources