Enfold Theme < 4.8.4 - Reflected Cross-Site Scripting (XSS)
Priority LOW 33CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Enfold Enfold WordPress theme before 4.8.4 was vulnerable to Reflected Cross-Site Scripting (XSS). The vulnerability is present on Enfold versions previous than 4.8.4 which use Avia Page Builder.
Why it matters now
EPSS 0.02959 87th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed Enfold (Unknown): 4.8.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Enfold | 4.8.4 to before 4.8.4 | 4.8.4 | Patch available | CNA |
- Enfold VendorUnknown Affected 4.8.4 to before 4.8.4 Fixed in 4.8.4 Patch available CNA
Remediation
- Fix · CNA Enfold (Unknown) Fixed in 4.8.4
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24719
- 2026-10-03 Alias added: GHSA-476w-cp8h-fwc5
References
More Kriesi Enfold vulnerabilities
- TI-2014-06080 Unspecified vulnerability in the folder framework in the Enfold theme before 3.0.1 for… CVSS 2.0HIGH 10.0
- TI-2024-24715 WordPress Enfold theme <= 5.6.9 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2023-19784 WordPress Enfold Theme <= 5.6.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2024-12732 Enfold <= 6.0.9 - Missing Authorization to Sensitive Information Disclosure in avia-export-class.php CVSS 3.1MEDIUM 5.3
- TI-2024-12734 Enfold <= 6.0.9 - Authenticated (Subscriber+) Server-Side Request Forgery via attachment_id CVSS 3.1MEDIUM 6.4
- TI-2024-04701 Enfold <= 6.0.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via wrapper_class and class Parameters CVSS 3.1MEDIUM 6.4
Sources
- CVE-2021-24719 · CVE Program
- CVE-2021-24719 · NVD
- FIRST EPSS
- GHSA-476w-cp8h-fwc5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences