Read the docs
TI-2021-07003 Aliases CVE-2021-24721GHSA-8mj6-23hc-v88f

Loco Translate < 2.5.4 - Authenticated PHP Code Injection

Priority LOW 31CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-94.

Summary

The Loco Translate WordPress plugin before 2.5.4 mishandles data inputs which get saved to a file, which can be renamed to an extension ending in .php, resulting in authenticated "translator" users being able to inject PHP code into files ending with .php in web accessible locations.

Why it matters now

EPSS 0.0094 61st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Loco Translate (Unknown): 2.5.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownLoco Translate2.5.4 to before 2.5.42.5.4Patch availableCNA
  • Loco Translate VendorUnknown Affected 2.5.4 to before 2.5.4 Fixed in 2.5.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:loco_translate_project:loco_translate:*:*:*:*:*:wordpress:*:*before 2.5.4VulnerableLoco Translate Project
  • cpe:2.3:a:loco_translate_project:loco_translate:*:*:*:*:*:wordpress:*:* Versions before 2.5.4 Vulnerable ·Loco Translate Project

Remediation

  • Fix · CNA Loco Translate (Unknown) Fixed in 2.5.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24721
  2. 2026-10-03 Alias added: GHSA-8mj6-23hc-v88f

References

  • TI-2022-00675 Loco Translate < 2.6.1 - Authenticated Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4

Sources