Dflip Lite < 1.7.10 - Contributor+ Stored Cross-Site Scripting
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The PDF Flipbook, 3D Flipbook WordPress – DearFlip WordPress plugin before 1.7.10 does not escape the class attribute of its shortcode before outputting it back in an attribute, which could allow users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks
Why it matters now
EPSS 0.0065 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed PDF Flipbook, 3D Flipbook WordPress – DearFlip (Unknown): 1.7.10
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | PDF Flipbook, 3D Flipbook WordPress – DearFlip | 1.7.10 to before 1.7.10 | 1.7.10 | Patch available | CNA |
- PDF Flipbook, 3D Flipbook WordPress – DearFlip VendorUnknown Affected 1.7.10 to before 1.7.10 Fixed in 1.7.10 Patch available CNA
Remediation
- Fix · CNA PDF Flipbook, 3D Flipbook WordPress – DearFlip (Unknown) Fixed in 1.7.10
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24732
- 2026-10-03 Alias added: GHSA-5jgv-8q3q-fffv
- 2026-10-16 EPSS moved to the 50th–90th percentile
References
More dearhive Dearflip vulnerabilities
- TI-2024-19583 WordPress DearFlip plugin <= 2.2.26 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-24732 · CVE Program
- CVE-2021-24732 · NVD
- FIRST EPSS
- GHSA-5jgv-8q3q-fffv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences