Compact WP Audio Player < 1.9.7 - Contributor+ Stored Cross-Site Scripting
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Compact WP Audio Player WordPress plugin before 1.9.7 does not escape some of its shortcodes attributes, which could allow users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks.
Why it matters now
EPSS 0.0065 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Compact WP Audio Player (Unknown): 1.9.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Compact WP Audio Player | 1.9.7 to before 1.9.7 | 1.9.7 | Patch available | CNA |
- Compact WP Audio Player VendorUnknown Affected 1.9.7 to before 1.9.7 Fixed in 1.9.7 Patch available CNA
Remediation
- Fix · CNA Compact WP Audio Player (Unknown) Fixed in 1.9.7
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Compact WP Audio Player 1.9.7
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2021-07017 Compact WP Audio Player < 1.9.7 - Setting Change via CSRFPriority LOW 30
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24734
- 2026-10-03 Alias added: GHSA-mc96-xvr9-9pqc
- 2026-10-16 EPSS moved to the 50th–90th percentile
References
More mra13 Compact Wp Audio Player vulnerabilities
- TI-2022-04146 Compact WP Audio Player < 1.9.8 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2021-07017 Compact WP Audio Player < 1.9.7 - Setting Change via CSRF CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-24734 · CVE Program
- CVE-2021-24734 · NVD
- FIRST EPSS
- GHSA-mc96-xvr9-9pqc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences