WP Performance Score Booster < 2.1 - Settings Change via CSRF
Priority LOW 20CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
The WP Performance Score Booster WordPress plugin before 2.1 does not have CSRF check when saving its settings, which could allow attackers to make a logged in admin change them via a CSRF attack.
Why it matters now
EPSS 0.0045 39th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WP Performance Score Booster – Optimize Speed, Enable Cache & Page Preload (Unknown): 2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Performance Score Booster – Optimize Speed, Enable Cache & Page Preload | 2.1 to before 2.1 | 2.1 | Patch available | CNA |
- WP Performance Score Booster – Optimize Speed, Enable Cache & Page Preload VendorUnknown Affected 2.1 to before 2.1 Fixed in 2.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wp_performance_score_booster_project:wp_performance_score_booster:*:*:*:*:*:wordpress:*:* | before 2.1 | Vulnerable | Wp Performance Score Booster Project |
- cpe:2.3:a:wp_performance_score_booster_project:wp_performance_score_booster:*:*:*:*:*:wordpress:*:* Versions before 2.1 Vulnerable ·Wp Performance Score Booster Project
Remediation
- Fix · CNA WP Performance Score Booster – Optimize Speed, Enable Cache & Page Preload (Unknown) Fixed in 2.1
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24776
- 2026-10-03 Alias added: GHSA-92wq-xf5r-xg8f
References
Sources
- CVE-2021-24776 · CVE Program
- CVE-2021-24776 · NVD
- FIRST EPSS
- GHSA-92wq-xf5r-xg8f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences