Client Invoicing by Sprout Invoices < 19.9.7 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Client Invoicing by Sprout Invoices WordPress plugin before 19.9.7 does not sanitise and escape some of its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Why it matters now
EPSS 0.00617 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Client Invoicing by Sprout Invoices – Easy Estimates and Invoices for WordPress (Unknown): 19.9.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Client Invoicing by Sprout Invoices – Easy Estimates and Invoices for WordPress | 19.9.7 to before 19.9.7 | 19.9.7 | Patch available | CNA |
- Client Invoicing by Sprout Invoices – Easy Estimates and Invoices for WordPress VendorUnknown Affected 19.9.7 to before 19.9.7 Fixed in 19.9.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:webventures:client_invoicing_by_sprout_invoices:*:*:*:*:*:wordpress:*:* | before 19.9.7 | Vulnerable | Webventures |
- cpe:2.3:a:webventures:client_invoicing_by_sprout_invoices:*:*:*:*:*:wordpress:*:* Versions before 19.9.7 Vulnerable ·Webventures
Remediation
- Fix · CNA Client Invoicing by Sprout Invoices – Easy Estimates and Invoices for WordPress (Unknown) Fixed in 19.9.7
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24787
- 2026-10-03 Alias added: GHSA-6gx4-hc8h-56hg
References
Sources
- CVE-2021-24787 · CVE Program
- CVE-2021-24787 · NVD
- FIRST EPSS
- GHSA-6gx4-hc8h-56hg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences