Far Future Expiry Header < 1.5 - Plugin's Settings Update via CSRF
Priority LOW 20CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
The Far Future Expiry Header WordPress plugin before 1.5 does not have CSRF check when saving its settings, which could allow attackers to make a logged in admin change them via a CSRF attack.
Why it matters now
EPSS 0.00468 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Far Future Expiry Header (Unknown): 1.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Far Future Expiry Header | 1.5 to before 1.5 | 1.5 | Patch available | CNA |
- Far Future Expiry Header VendorUnknown Affected 1.5 to before 1.5 Fixed in 1.5 Patch available CNA
Remediation
- Fix · CNA Far Future Expiry Header (Unknown) Fixed in 1.5
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24799
- 2026-10-03 Alias added: GHSA-vh87-pq75-243h
References
Sources
- CVE-2021-24799 · CVE Program
- CVE-2021-24799 · NVD
- FIRST EPSS
- GHSA-vh87-pq75-243h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences