Shop Page WP < 1.2.8 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Shop Page WP WordPress plugin before 1.2.8 does not sanitise and escape some of the Product fields, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Why it matters now
EPSS 0.00617 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Shop Page WP (Unknown): 1.2.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Shop Page WP | 1.2.8 to before 1.2.8 | 1.2.8 | Patch available | CNA |
- Shop Page WP VendorUnknown Affected 1.2.8 to before 1.2.8 Fixed in 1.2.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:shoppagewp:shop_page_wp:*:*:*:*:*:wordpress:*:* | before 1.2.8 | Vulnerable | Shoppagewp |
- cpe:2.3:a:shoppagewp:shop_page_wp:*:*:*:*:*:wordpress:*:* Versions before 1.2.8 Vulnerable ·Shoppagewp
Remediation
- Fix · CNA Shop Page WP (Unknown) Fixed in 1.2.8
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24811
- 2026-10-03 Alias added: GHSA-qmx3-vr4p-7jgf
References
Sources
- CVE-2021-24811 · CVE Program
- CVE-2021-24811 · NVD
- FIRST EPSS
- GHSA-qmx3-vr4p-7jgf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences