Helpful < 4.4.59 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Helpful WordPress plugin before 4.4.59 does not sanitise and escape some of its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Why it matters now
EPSS 0.00757 55th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed Helpful (Unknown): 4.4.59
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Helpful | 4.4.59 to before 4.4.59 | 4.4.59 | Patch available | CNA |
- Helpful VendorUnknown Affected 4.4.59 to before 4.4.59 Fixed in 4.4.59 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:helpful_project:helpful:*:*:*:*:*:wordpress:*:* | before 4.4.59 | Vulnerable | Helpful Project |
- cpe:2.3:a:helpful_project:helpful:*:*:*:*:*:wordpress:*:* Versions before 4.4.59 Vulnerable ·Helpful Project
Remediation
- Fix · CNA Helpful (Unknown) Fixed in 4.4.59
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24841
- 2026-10-03 Alias added: GHSA-w23j-r8pr-6978
References
More Helpful Project Helpful vulnerabilities
- TI-2022-02628 Helpful < 4.5.26 - Information Disclosure CVSS 3.1MEDIUM 5.3
Sources
- CVE-2021-24841 · CVE Program
- CVE-2021-24841 · NVD
- FIRST EPSS
- GHSA-w23j-r8pr-6978 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences