Get Custom Field Values < 4.0.1 - Contributor+ Stored Cross-Site Scripting
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Get Custom Field Values WordPress plugin before 4.0.1 does not escape custom fields before outputting them in the page, which could allow users with a role as low as contributor to perform Cross-Site Scripting attacks
Why it matters now
EPSS 0.00707 53rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Get Custom Field Values (Unknown): 4.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Get Custom Field Values | 4.0.1 to before 4.0.1 | 4.0.1 | Patch available | CNA |
- Get Custom Field Values VendorUnknown Affected 4.0.1 to before 4.0.1 Fixed in 4.0.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:get_custom_field_values_project:get_custom_field_values:*:*:*:*:*:wordpress:*:* | before 4.0.1 | Vulnerable | Get Custom Field Values Project |
- cpe:2.3:a:get_custom_field_values_project:get_custom_field_values:*:*:*:*:*:wordpress:*:* Versions before 4.0.1 Vulnerable ·Get Custom Field Values Project
Remediation
- Fix · CNA Get Custom Field Values (Unknown) Fixed in 4.0.1
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24871
- 2026-10-03 Alias added: GHSA-xvr9-h38m-rc5q
References
More Get Custom Field Values Project Get Custom Field Values vulnerabilities
- TI-2021-07154 Get Custom Field Values < 4.0 - Contributors+ Arbitrary Post Metadata Access CVSS 3.1MEDIUM 6.5
- TI-2023-24407 WordPress Get Custom Field Values Plugin <= 4.0.1 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2021-24871 · CVE Program
- CVE-2021-24871 · NVD
- FIRST EPSS
- GHSA-xvr9-h38m-rc5q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences