Cybersoldier < 1.7.0 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Cybersoldier WordPress plugin before 1.7.0 does not sanitise and escape the URL settings before outputting it in an attribute, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Why it matters now
EPSS 0.00598 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Cybersoldier (Unknown): 1.7.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Cybersoldier | 1.7.0 to before 1.7.0 | 1.7.0 | Patch available | CNA |
- Cybersoldier VendorUnknown Affected 1.7.0 to before 1.7.0 Fixed in 1.7.0 Patch available CNA
Remediation
- Fix · CNA Cybersoldier (Unknown) Fixed in 1.7.0
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24895
- 2026-10-03 Alias added: GHSA-7gx5-vxvp-w58w
References
Sources
- CVE-2021-24895 · CVE Program
- CVE-2021-24895 · NVD
- FIRST EPSS
- GHSA-7gx5-vxvp-w58w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences