Read the docs
TI-2021-07207 Aliases CVE-2021-24927GHSA-gcvg-gpgp-f6cf

My Calendar < 3.2.18 - Subscriber+ Reflected Cross-Site Scripting

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The My Calendar WordPress plugin before 3.2.18 does not sanitise and escape the callback parameter of the mc_post_lookup AJAX action (available to any authenticated user) before outputting it back in the response, leading to a Reflected Cross-Site Scripting issue

Why it matters now

EPSS 0.0062 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed My Calendar (Unknown): 3.2.18

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownMy Calendar3.2.18 to before 3.2.183.2.18Patch availableCNA
  • My Calendar VendorUnknown Affected 3.2.18 to before 3.2.18 Fixed in 3.2.18 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:my_calendar_project:my_calendar:*:*:*:*:*:wordpress:*:*before 3.2.18VulnerableMy Calendar Project
  • cpe:2.3:a:my_calendar_project:my_calendar:*:*:*:*:*:wordpress:*:* Versions before 3.2.18 Vulnerable ·My Calendar Project

Remediation

  • Fix · CNA My Calendar (Unknown) Fixed in 3.2.18

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24927
  2. 2026-10-03 Alias added: GHSA-gcvg-gpgp-f6cf

References

  • TI-2023-09612 WordPress My Calendar Plugin <= 3.4.3 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2022-23504 WordPress My Calendar Plugin <= 3.3.24.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2019-11795 The my-calendar plugin before 3.1.10 for WordPress has XSS. CVSS 3.0MEDIUM 6.1

Sources