Read the docs
TI-2021-07252 Aliases CVE-2021-24973GHSA-4p7m-87rg-hcph

Site Reviews < 5.17.3 - Unauthenticated Stored Cross-Site Scripting

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Site Reviews WordPress plugin before 5.17.3 does not sanitise and escape the site-reviews parameter of the glsr_action AJAX action (available to unauthenticated and any authenticated users), allowing them to perform Cross-Site Scripting attacks against logged in admins viewing the Tool dashboard of the plugin

Why it matters now

EPSS 0.01335 71st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Site Reviews (Unknown): 5.17.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownSite Reviews5.17.3 to before 5.17.35.17.3Patch availableCNA
  • Site Reviews VendorUnknown Affected 5.17.3 to before 5.17.3 Fixed in 5.17.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:geminilabs:site_reviews:*:*:*:*:*:wordpress:*:*before 5.17.3VulnerableGemini Labs
  • cpe:2.3:a:geminilabs:site_reviews:*:*:*:*:*:wordpress:*:* Versions before 5.17.3 Vulnerable ·Gemini Labs

Remediation

  • Fix · CNA Site Reviews (Unknown) Fixed in 5.17.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24973
  2. 2026-10-03 Alias added: GHSA-4p7m-87rg-hcph

References

  • TI-2024-02856 Site Reviews < 7.0.0 - IP Spoofing CVSS 3.1CRITICAL 9.1
  • TI-2025-01056 Site Reviews < 7.2.5 - Unauthenticated Stored XSS CVSS 3.1HIGH 8.8
  • TI-2023-01439 Site Reviews < 6.7.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2022-23147 WordPress Site Reviews Plugin <= 6.2.0 is vulnerable to CSV Injection CVSS 3.1CRITICAL 9.8
  • TI-2018-00560 Cross-site scripting in Gemini Labs Site Reviews CVSS 3.0MEDIUM 6.1
  • TI-2023-12339 WordPress Site Reviews Plugin <= 6.5.1 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
See all 8 →

Sources