Use Any Font < 6.2.1 - Unauthenticated Arbitrary CSS Appending
Priority LOW 30CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-862.
Summary
The Use Any Font | Custom Font Uploader WordPress plugin before 6.2.1 does not have any authorisation checks when assigning a font, allowing unauthenticated users to sent arbitrary CSS which will then be processed by the frontend for all users. Due to the lack of sanitisation and escaping in the backend, it could also lead to Stored XSS issues
Why it matters now
EPSS 0.01492 74th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Use Any Font | Custom Font Uploader (Unknown): 6.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Use Any Font | Custom Font Uploader | 6.2.1 to before 6.2.1 | 6.2.1 | Patch available | CNA |
- Use Any Font | Custom Font Uploader VendorUnknown Affected 6.2.1 to before 6.2.1 Fixed in 6.2.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dineshkarki:use_any_font:*:*:*:*:*:wordpress:*:* | before 6.2.1 | Vulnerable | Dinesh Karki |
- cpe:2.3:a:dineshkarki:use_any_font:*:*:*:*:*:wordpress:*:* Versions before 6.2.1 Vulnerable ·Dinesh Karki
Remediation
- Fix · CNA Use Any Font | Custom Font Uploader (Unknown) Fixed in 6.2.1
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24977
- 2026-10-03 Alias added: GHSA-vj7q-773h-8qqf
References
More Dinesh Karki Use Any Font vulnerabilities
- TI-2024-31623 WordPress Use Any Font plugin <= 6.3.08 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
- TI-2022-10734 WordPress Use Any Font plugin <= 6.1.7 - Cross-Site Request Forgery (CSRF) vulnerability CVSS 3.1MEDIUM 5.4
Sources
- CVE-2021-24977 · CVE Program
- CVE-2021-24977 · NVD
- FIRST EPSS
- GHSA-vj7q-773h-8qqf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences