Buttonizer - Smart Floating Action Button < 2.5.5 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Smart Floating / Sticky Buttons WordPress plugin before 2.5.5 does not sanitise and escape some parameter before outputting them in attributes and page, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Why it matters now
EPSS 0.00617 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Smart Floating / Sticky Buttons – Call, Sharing, Chat Widgets & More – Buttonizer (Unknown): 2.5.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Smart Floating / Sticky Buttons – Call, Sharing, Chat Widgets & More – Buttonizer | 2.5.5 to before 2.5.5 | 2.5.5 | Patch available | CNA |
- Smart Floating / Sticky Buttons – Call, Sharing, Chat Widgets & More – Buttonizer VendorUnknown Affected 2.5.5 to before 2.5.5 Fixed in 2.5.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:buttonizer:buttonizer:*:*:*:*:*:wordpress:*:* | before 2.5.5 | Vulnerable | Buttonizer |
- cpe:2.3:a:buttonizer:buttonizer:*:*:*:*:*:wordpress:*:* Versions before 2.5.5 Vulnerable ·Buttonizer
Remediation
- Fix · CNA Smart Floating / Sticky Buttons – Call, Sharing, Chat Widgets & More – Buttonizer (Unknown) Fixed in 2.5.5
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24992
- 2026-10-03 Alias added: GHSA-3c38-2c7r-g6j4
References
Sources
- CVE-2021-24992 · CVE Program
- CVE-2021-24992 · NVD
- FIRST EPSS
- GHSA-3c38-2c7r-g6j4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences