Booking Calendar < 8.9.2 - Reflected Cross-Site Scripting
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Booking Calendar WordPress plugin before 8.9.2 does not sanitise and escape the booking_type parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting
Why it matters now
EPSS 0.00827 57th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Booking Calendar (Unknown): 8.9.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Booking Calendar | 8.9.2 to before 8.9.2 | 8.9.2 | Patch available | CNA |
- Booking Calendar VendorUnknown Affected 8.9.2 to before 8.9.2 Fixed in 8.9.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:booking_calendar_project:booking_calendar:*:*:*:*:*:wordpress:*:* | before 8.9.2 | Vulnerable | Booking Calendar Project |
- cpe:2.3:a:booking_calendar_project:booking_calendar:*:*:*:*:*:wordpress:*:* Versions before 8.9.2 Vulnerable ·Booking Calendar Project
Remediation
- Fix · CNA Booking Calendar (Unknown) Fixed in 8.9.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25040
- 2026-10-03 Alias added: GHSA-98qq-vrv8-7p4q
References
More Booking Calendar Project Booking Calendar vulnerabilities
- TI-2018-14579 SQL injection vulnerability in Booking Calendar plugin 8.4.3 for WordPress allows remote… CVSS 3.0HIGH 8.8
- TI-2022-01337 Booking Calendar <= 9.1 - PHP Object Injection via Shortcode CVSS 3.1HIGH 8.8
- TI-2018-04084 An issue was discovered in the booking-calendar plugin 2.1.7 for WordPress. CVSS 3.0HIGH 8.8
- TI-2023-18247 WordPress Booking Calendar Contact Form Plugin <= 1.2.40 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2017-01454 Cross-site scripting in wpdevelop Booking Calendar CVSS 3.0MEDIUM 6.1
- TI-2017-01453 Path traversal in wpdevelop Booking Calendar CVSS 3.0MEDIUM 5.3
Sources
- CVE-2021-25040 · CVE Program
- CVE-2021-25040 · NVD
- FIRST EPSS
- GHSA-98qq-vrv8-7p4q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences