WOOCS < 1.3.7.3 - Reflected Cross-Site Scripting
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WOOCS WordPress plugin before 1.3.7.3 does not sanitise and escape the custom_prices parameter before outputting it back in the response, leading to a Reflected Cross-Site Scripting issue
Why it matters now
EPSS 0.00905 60th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WOOCS – Currency Switcher for WooCommerce. Professional and Free multi currency plugin – Pay in selected currency (Unknown): 1.3.7.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WOOCS – Currency Switcher for WooCommerce. Professional and Free multi currency plugin – Pay in selected currency | 1.3.7.3 to before 1.3.7.3 | 1.3.7.3 | Patch available | CNA |
- WOOCS – Currency Switcher for WooCommerce. Professional and Free multi currency plugin – Pay in selected currency VendorUnknown Affected 1.3.7.3 to before 1.3.7.3 Fixed in 1.3.7.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pluginus:woocommerce_currency_switcher:*:*:*:*:*:wordpress:*:* | before 1.3.7.3 | Vulnerable | realmag777 |
- cpe:2.3:a:pluginus:woocommerce_currency_switcher:*:*:*:*:*:wordpress:*:* Versions before 1.3.7.3 Vulnerable ·realmag777
Remediation
- Fix · CNA WOOCS – Currency Switcher for WooCommerce. Professional and Free multi currency plugin – Pay in selected currency (Unknown) Fixed in 1.3.7.3
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25043
- 2026-10-03 Alias added: GHSA-ccjq-ghp2-2g5m
References
Sources
- CVE-2021-25043 · CVE Program
- CVE-2021-25043 · NVD
- FIRST EPSS
- GHSA-ccjq-ghp2-2g5m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences