Read the docs
TI-2021-07330 Aliases CVE-2021-25052GHSA-qgxx-xcvx-3pp5

Button Generator < 2.3.3 - RFI leading to RCE via CSRF

Priority MEDIUM 44CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.

Summary

The Button Generator WordPress plugin before 2.3.3 within the wow-company admin menu page allows to include() arbitrary file with PHP extension (as well as with data:// or http:// protocols), thus leading to CSRF RCE.

Why it matters now

EPSS 0.03032 87th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Button Generator – easily Button Builder (Unknown): 2.3.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownButton Generator – easily Button Builder2.3.3 to before 2.3.32.3.3Patch availableCNA
  • Button Generator – easily Button Builder VendorUnknown Affected 2.3.3 to before 2.3.3 Fixed in 2.3.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wow-company:button_generator:*:*:*:*:*:wordpress:*:*before 2.3.3VulnerableWow-Company
  • cpe:2.3:a:wow-company:button_generator:*:*:*:*:*:wordpress:*:* Versions before 2.3.3 Vulnerable ·Wow-Company

Remediation

  • Fix · CNA Button Generator – easily Button Builder (Unknown) Fixed in 2.3.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-25052
  2. 2026-10-03 Alias added: GHSA-qgxx-xcvx-3pp5

References

  • TI-2023-02217 Multiple Plugins from Wow-Company - Reflected XSS CVSS 3.1MEDIUM 6.1
  • TI-2023-26814 WordPress Button Generator – easily Button Builder Plugin <= 2.3.8 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2023-10753 WordPress Button Generator – easily Button Builder Plugin <= 2.3.5 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1MEDIUM 6.5
  • TI-2024-03236 Button Generator < 3.0 - Button Deletion via CSRF CVSS 3.1LOW 3.4

Sources