Read the docs
TI-2021-07331 Aliases CVE-2021-25053GHSA-pw9r-237f-q334

WP Coder < 2.5.2 - RFI leading to RCE via CSRF

Priority LOW 39CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.

Summary

The WP Coder WordPress plugin before 2.5.2 within the wow-company admin menu page allows to include() arbitrary file with PHP extension (as well as with data:// or http:// protocols), thus leading to CSRF RCE.

Why it matters now

EPSS 0.00692 53rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WP Coder – add custom html, css and js code (Unknown): 2.5.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP Coder – add custom html, css and js code2.5.2 to before 2.5.22.5.2Patch availableCNA
  • WP Coder – add custom html, css and js code VendorUnknown Affected 2.5.2 to before 2.5.2 Fixed in 2.5.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wow-company:wp_coder:*:*:*:*:*:wordpress:*:*before 2.5.2VulnerableWow-Company
  • cpe:2.3:a:wow-company:wp_coder:*:*:*:*:*:wordpress:*:* Versions before 2.5.2 Vulnerable ·Wow-Company

Remediation

  • Fix · CNA WP Coder – add custom html, css and js code (Unknown) Fixed in 2.5.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-25053
  2. 2026-10-03 Alias added: GHSA-pw9r-237f-q334

References

  • TI-2023-02217 Multiple Plugins from Wow-Company - Reflected XSS CVSS 3.1MEDIUM 6.1
  • TI-2023-00847 WP Coder – add custom html, css and js code <= 2.5.3 - Authenticated (Admin+) SQL Injection CVSS 3.1HIGH 7.2
  • TI-2022-02204 WP Coder < 2.5.3 - Code Deletion via CSRF CVSS 3.1MEDIUM 6.5
  • TI-2024-02398 WordPress WP Coder plugin <= 3.5 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.9

Sources