Read the docs
TI-2021-07339 Aliases CVE-2021-25061GHSA-vmjf-9395-7q9j

WP Booking System – Booking Calendar < 2.0.15 - Authenticated Reflected Cross-Site Scripting (XSS)

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The WP Booking System WordPress plugin before 2.0.15 was affected by a reflected xss in wp-booking-system on the wpbs-calendars admin page.

Why it matters now

EPSS 0.00675 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WP Booking System – Booking Calendar (Unknown): 2.0.15

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP Booking System – Booking Calendar2.0.15 to before 2.0.152.0.15Patch availableCNA
  • WP Booking System – Booking Calendar VendorUnknown Affected 2.0.15 to before 2.0.15 Fixed in 2.0.15 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpbookingsystem:wp_booking_system:*:*:*:*:*:wordpress:*:*before 2.0.15VulnerableWP Booking System
  • cpe:2.3:a:wpbookingsystem:wp_booking_system:*:*:*:*:*:wordpress:*:* Versions before 2.0.15 Vulnerable ·WP Booking System

Remediation

  • Fix · CNA WP Booking System – Booking Calendar (Unknown) Fixed in 2.0.15

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-25061
  2. 2026-10-03 Alias added: GHSA-vmjf-9395-7q9j

References

  • TI-2019-09130 The WP Booking System plugin 1.5.1 for WordPress has no CSRF protection, which allows… CVSS 3.1HIGH 7.2
  • TI-2017-01469 Cross-site scripting in WP Booking System Free version CVSS 3.0MEDIUM 6.1
  • TI-2024-08163 WP Booking System – Booking Calendar <= 2.0.19.8 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
  • TI-2023-10024 WordPress WP Booking System Plugin <= 2.0.18 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9

Sources