Store Toolkit for WooCommerce < 2.3.2 - Reflected Cross-Site Scripting
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Store Toolkit for WooCommerce WordPress plugin before 2.3.2 does not sanitise and escape the tab parameter before outputting it back in an admin page in an error message, leading to a Reflected Cross-Site Scripting
Why it matters now
EPSS 0.00876 59th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Store Toolkit for WooCommerce (Unknown): 2.3.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Store Toolkit for WooCommerce | 2.3.2 to before 2.3.2 | 2.3.2 | Patch available | CNA |
- Store Toolkit for WooCommerce VendorUnknown Affected 2.3.2 to before 2.3.2 Fixed in 2.3.2 Patch available CNA
Remediation
- Fix · CNA Store Toolkit for WooCommerce (Unknown) Fixed in 2.3.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25077
- 2026-10-03 Alias added: GHSA-56vv-w8x4-c263
References
More Visser Store Toolkit For Woocommerce vulnerabilities
- TI-2016-08961 The woocommerce-store-toolkit plugin before 1.5.8 for WordPress has privilege escalation. CVSS 3.0CRITICAL 9.8
- TI-2016-08960 The woocommerce-store-toolkit plugin before 1.5.7 for WordPress has privilege escalation. CVSS 3.0CRITICAL 9.8
Sources
- CVE-2021-25077 · CVE Program
- CVE-2021-25077 · NVD
- FIRST EPSS
- GHSA-56vv-w8x4-c263 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences