IP2Location Country Blocker < 2.26.5 - Subscriber+ Arbitrary Country Ban
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Tampering, Security bypass
- Confidentiality · integrity · availability
- None · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352 and CWE-862.
Summary
The IP2Location Country Blocker WordPress plugin before 2.26.5 does not have authorisation and CSRF checks in the ip2location_country_blocker_save_rules AJAX action, allowing any authenticated users, such as subscriber to call it and block arbitrary country, or block all of them at once, preventing users from accessing the frontend.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | IP2Location Country Blocker | 2.26.5 to before 2.26.5 | 2.26.5 | Patch available | CNA |
- IP2Location Country Blocker VendorUnknown Affected 2.26.5 to before 2.26.5 Fixed in 2.26.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ip2location:country_blocker:*:*:*:*:*:wordpress:*:* | before 2.26.5 | Vulnerable | IP2Location |
- cpe:2.3:a:ip2location:country_blocker:*:*:*:*:*:wordpress:*:* Versions before 2.26.5 Vulnerable ·IP2Location
Remediation
- Fix · CNA IP2Location Country Blocker (Unknown) Fixed in 2.26.5
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
IP2Location Country Blocker 2.26.5
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2021-07374 IP2Location Country Blocker < 2.26.5 - Ban BypassPriority LOW 31
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25095
- 2026-10-03 Alias added: GHSA-hgh9-57mp-975h
References
More IP2Location Country Blocker vulnerabilities
- TI-2025-01166 Improper authorization in IP2Location Country Blocker CVSS 3.1HIGH 7.5
- TI-2024-14881 WordPress Download IP2Location Country Blocker Plugin <= 2.33.3 is vulnerable to Sensitive Data Exposure CVSS 3.1HIGH 7.5
- TI-2024-21338 WordPress IP2Location Country Blocker plugin <= 2.34.2 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
- TI-2021-07386 IP2Location Country Blocker < 2.26.6 - Arbitrary Country Ban via CSRF CVSS 3.1HIGH 7.1
- TI-2021-07374 IP2Location Country Blocker < 2.26.5 - Ban Bypass CVSS 3.1MEDIUM 6.5
- TI-2025-18448 WordPress IP2Location Country Blocker plugin <= 2.38.3 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.9
Sources
- CVE-2021-25095 · CVE Program
- CVE-2021-25095 · NVD
- FIRST EPSS
- GHSA-hgh9-57mp-975h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences