All In One WP Security < 4.4.11 - Authenticated Reflected Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The All In One WP Security & Firewall WordPress plugin before 4.4.11 does not validate, sanitise and escape the redirect_to parameter before using it to redirect user, either via a Location header, or meta url attribute, when the Rename Login Page is active, which could lead to an Arbitrary Redirect as well as Cross-Site Scripting issue. Exploitation of this issue requires the Login Page URL value to be known, which should be hard to guess, reducing the risk
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | All In One WP Security & Firewall | 4.4.11 to before 4.4.11 | 4.4.11 | Patch available | CNA |
- All In One WP Security & Firewall VendorUnknown Affected 4.4.11 to before 4.4.11 Fixed in 4.4.11 Patch available CNA
Remediation
- Fix · CNA All In One WP Security & Firewall (Unknown) Fixed in 4.4.11
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25102
- 2026-10-03 Alias added: GHSA-jw24-79q4-qcv5
References
More mra13 All In One Wp Security & Firewall vulnerabilities
- TI-2016-08926 The all-in-one-wp-security-and-firewall plugin before 4.0.7 for WordPress has multiple SQL injection issues. CVSS 3.0CRITICAL 9.8
- TI-2016-08925 The all-in-one-wp-security-and-firewall plugin before 4.0.9 for WordPress has multiple SQL injection issues. CVSS 3.0CRITICAL 9.8
- TI-2015-07687 The all-in-one-wp-security-and-firewall plugin before 3.9.1 for WordPress has multiple SQL injection issues. CVSS 3.0CRITICAL 9.8
- TI-2022-22026 WordPress All In One WP Security plugin <= 5.1.0 - Multiple Cross-Site Request Forgery (CSRF) vulnerabilities CVSS 3.1HIGH 8.8
- TI-2016-08906 The all-in-one-wp-security-and-firewall plugin before 4.0.5 for WordPress has XSS in the… CVSS 3.0MEDIUM 6.1
- TI-2016-08905 The all-in-one-wp-security-and-firewall plugin before 4.0.6 for WordPress has XSS in settings pages. CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-25102 · CVE Program
- CVE-2021-25102 · NVD
- FIRST EPSS
- GHSA-jw24-79q4-qcv5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences