WPLegalPages < 2.7.1 - Subscriber+ Arbitrary Settings Update to Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Privacy Policy Generator, Terms & Conditions Generator WordPress Plugin : WPLegalPages WordPress plugin before 2.7.1 does not check for authorisation and has a flawed CSRF logic when saving its settings, allowing any authenticated users, such as subscriber, to update them. Furthermore, due to the lack of sanitisation and escaping, it could lead to Stored Cross-Site Scripting
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Privacy Policy Generator, Terms & Conditions Generator WordPress Plugin : WPLegalPages | 2.7.1 to before 2.7.1 | 2.7.1 | Patch available | CNA |
- Privacy Policy Generator, Terms & Conditions Generator WordPress Plugin : WPLegalPages VendorUnknown Affected 2.7.1 to before 2.7.1 Fixed in 2.7.1 Patch available CNA
Remediation
- Fix · CNA Privacy Policy Generator, Terms & Conditions Generator WordPress Plugin : WPLegalPages (Unknown) Fixed in 2.7.1
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25106
- 2026-10-03 Alias added: GHSA-h2hg-rvg6-p5x3
References
More WPeka Wplegalpages vulnerabilities
- TI-2023-04573 WPLegalPages <= 2.9.2 - Authenticated (Author+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 5.5
Sources
- CVE-2021-25106 · CVE Program
- CVE-2021-25106 · NVD
- FIRST EPSS
- GHSA-h2hg-rvg6-p5x3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences