WHMCS Bridge < 6.4b - Reflected Cross-Site Scripting (XSS)
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WHMCS Bridge WordPress plugin before 6.4b does not sanitise and escape the error parameter before outputting it back in admin dashboard, leading to a Reflected Cross-Site Scripting
Why it matters now
EPSS 0.02187 82nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WHMCS Bridge (Unknown): 6.4b
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WHMCS Bridge | 6.4b to before 6.4b | 6.4b | Patch available | CNA |
- WHMCS Bridge VendorUnknown Affected 6.4b to before 6.4b Fixed in 6.4b Patch available CNA
Remediation
- Fix · CNA WHMCS Bridge (Unknown) Fixed in 6.4b
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25112
- 2026-10-03 Alias added: GHSA-pv99-qp9p-g563
References
More I-plugins Whmcs Bridge vulnerabilities
- TI-2021-02958 WHMCS Bridge <= 6.1 Subscriber+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
Sources
- CVE-2021-25112 · CVE Program
- CVE-2021-25112 · NVD
- FIRST EPSS
- GHSA-pv99-qp9p-g563 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences