Read the docs
TI-2021-07478 Aliases CVE-2021-25218GHSA-cc8x-chx9-c63q

Reachable assertion in ISC BIND9

Priority LOW 39CWE-617Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-617.

Summary

In BIND 9.16.19, 9.17.16. Also, version 9.16.19-S1 of BIND Supported Preview Edition When a vulnerable version of named receives a query under the circumstances described above, the named process will terminate due to a failed assertion check. The vulnerability affects only BIND 9 releases 9.16.19, 9.17.16, and release 9.16.19-S1 of the BIND Supported Preview Edition.

Why it matters now

EPSS 0.03658 89th percentileScored 2026-11-08
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND9Stable Branch 9.16.19; Development Branch 9.17.16; Supported Preview Edition 9.16.19-S1—No fix listedCNA
  • BIND9 VendorISC Affected Stable Branch 9.16.19; Development Branch 9.17.16; Supported Preview Edition 9.16.19-S1 Fixed in — No fix listed CNA

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.16.19:*:*:*:-:*:*:*9.16.19VulnerableISC
cpe:2.3:a:isc:bind:9.17.16:*:*:*:-:*:*:*9.17.16VulnerableISC
cpe:2.3:a:isc:bind:9.17.16:s1:*:*:supported_preview:*:*:*9.17.16 s1VulnerableISC
cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:*34VulnerableFedoraproject
  • cpe:2.3:a:isc:bind:9.16.19:*:*:*:-:*:*:* Versions 9.16.19 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.17.16:*:*:*:-:*:*:* Versions 9.17.16 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.17.16:s1:*:*:supported_preview:*:*:* Versions 9.17.16 s1 Vulnerable ·ISC
  • cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject

Remediation

No fixed version listed by the sources yet.

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

Not affected: 5 products
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9
  • Red Hat Virtualization 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-25218
  2. 2026-10-03 Alias added: GHSA-cc8x-chx9-c63q

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources