hawk: Insecure file permissions
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
A Creation of Temporary File With Insecure Permissions vulnerability in hawk2 of SUSE Linux Enterprise High Availability 12-SP3, SUSE Linux Enterprise High Availability 12-SP5, SUSE Linux Enterprise High Availability 15-SP2 allows local attackers to escalate to root. This issue affects: SUSE Linux Enterprise High Availability 12-SP3 hawk2 versions prior to 2.6.3+git.1614685906.812c31e9. SUSE Linux Enterprise High Availability 12-SP5 hawk2 versions prior to 2.6.3+git.1614685906.812c31e9. SUSE Linux Enterprise High Availability 15-SP2 hawk2 versions prior to 2.6.3+git.1614684118.af555ad9.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | SUSE Linux Enterprise High Availability 12-SP3 | hawk2 to before 2.6.3+git.1614685906.812c31e9 | 2.6.3+git.1614685906.812c31e9 | Patch available | CNA |
| SUSE | SUSE Linux Enterprise High Availability 12-SP5 | hawk2 to before 2.6.3+git.1614685906.812c31e9 | 2.6.3+git.1614685906.812c31e9 | Patch available | CNA |
| SUSE | SUSE Linux Enterprise High Availability 15-SP2 | hawk2 to before 2.6.3+git.1614684118.af555ad9 | 2.6.3+git.1614684118.af555ad9 | Patch available | CNA |
- SUSE Linux Enterprise High Availability 12-SP3 VendorSUSE Affected hawk2 to before 2.6.3+git.1614685906.812c31e9 Fixed in 2.6.3+git.1614685906.812c31e9 Patch available CNA
- SUSE Linux Enterprise High Availability 12-SP5 VendorSUSE Affected hawk2 to before 2.6.3+git.1614685906.812c31e9 Fixed in 2.6.3+git.1614685906.812c31e9 Patch available CNA
- SUSE Linux Enterprise High Availability 15-SP2 VendorSUSE Affected hawk2 to before 2.6.3+git.1614684118.af555ad9 Fixed in 2.6.3+git.1614684118.af555ad9 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:suse:hawk2:*:*:*:*:*:*:*:* | before 2.6.3\+git.1614685906.812c31e9-2.42.1 | Vulnerable | SUSE |
| cpe:2.3:o:suse:linux_enterprise_high_availability_extension:12:sp3:*:*:*:*:*:* | 12 sp3 | Running on | SUSE |
| cpe:2.3:a:suse:hawk2:*:*:*:*:*:*:*:* | before 2.6.3\+git.1614684118.af555ad9 | Vulnerable | SUSE |
| cpe:2.3:o:suse:linux_enterprise_high_availability_extension:15:sp2:*:*:*:*:*:* | 15 sp2 | Running on | SUSE |
| cpe:2.3:a:suse:hawk2:*:*:*:*:*:*:*:* | before 2.6.3\+git.1614685906.812c31e9 | Vulnerable | SUSE |
| cpe:2.3:o:suse:linux_enterprise_high_availability_extension:12:sp5:*:*:*:*:*:* | 12 sp5 | Running on | SUSE |
- cpe:2.3:a:suse:hawk2:*:*:*:*:*:*:*:* Versions before 2.6.3\+git.1614685906.812c31e9-2.42.1 Vulnerable ·SUSE
- cpe:2.3:o:suse:linux_enterprise_high_availability_extension:12:sp3:*:*:*:*:*:* Versions 12 sp3 Running on ·SUSE
- cpe:2.3:a:suse:hawk2:*:*:*:*:*:*:*:* Versions before 2.6.3\+git.1614684118.af555ad9 Vulnerable ·SUSE
- cpe:2.3:o:suse:linux_enterprise_high_availability_extension:15:sp2:*:*:*:*:*:* Versions 15 sp2 Running on ·SUSE
- cpe:2.3:a:suse:hawk2:*:*:*:*:*:*:*:* Versions before 2.6.3\+git.1614685906.812c31e9 Vulnerable ·SUSE
- cpe:2.3:o:suse:linux_enterprise_high_availability_extension:12:sp5:*:*:*:*:*:* Versions 12 sp5 Running on ·SUSE
Remediation
- Fix · CNA SUSE Linux Enterprise High Availability 12-SP3 (SUSE) Fixed in 2.6.3+git.1614685906.812c31e9
- Fix · CNA SUSE Linux Enterprise High Availability 12-SP5 (SUSE) Fixed in 2.6.3+git.1614685906.812c31e9
- Fix · CNA SUSE Linux Enterprise High Availability 15-SP2 (SUSE) Fixed in 2.6.3+git.1614684118.af555ad9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25314
- 2026-10-03 Alias added: GHSA-4f3q-6cq7-8w4p
References
Sources
- CVE-2021-25314 · CVE Program
- CVE-2021-25314 · NVD
- FIRST EPSS
- GHSA-4f3q-6cq7-8w4p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences