Improper privilege management in Collabora Online
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269.
Summary
"loolforkit" is a privileged program that is supposed to be run by a special, non-privileged "lool" user. Before doing anything else "loolforkit" checks, if it was invoked by the "lool" user, and refuses to run with privileges, if it's not the case. In the vulnerable version of "loolforkit" this check was wrong, so a normal user could start "loolforkit" and eventually get local root privileges.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Collabora Productivity | Collabora Online | Collabora Online 4.2 to before 4.2.13; Collabora Online 6.4 to before 6.4.3 | 4.2.13, 6.4.3 | Patch available | CNA |
| The Document Foundation | LibreOffice Online | up to 7.0.1.1 | — | No fix listed | CNA |
- Collabora Online VendorCollabora Productivity Affected Collabora Online 4.2 to before 4.2.13; Collabora Online 6.4 to before 6.4.3 Fixed in 4.2.13, 6.4.3 Patch available CNA
- LibreOffice Online VendorThe Document Foundation Affected up to 7.0.1.1 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:collaboraoffice:online:*:*:*:*:*:*:*:* | 4.2.0 to before 4.2.13; 6.4.0 to before 6.4.3 | Vulnerable | Collaboraoffice |
- cpe:2.3:a:collaboraoffice:online:*:*:*:*:*:*:*:* Versions 4.2.0 to before 4.2.13; 6.4.0 to before 6.4.3 Vulnerable ·Collaboraoffice
Remediation
- Fix · CNA Collabora Online (Collabora Productivity) Fixed in 4.2.13, 6.4.3
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25630
References
More The Document Foundation vulnerabilities
- TI-2019-07233 LibreLogo global-event script execution CVSS 3.1CRITICAL 9.8
- TI-2018-12068 Path traversal in [UNKNOWN] libreoffice CVSS 3.0CRITICAL 9.8
- TI-2018-07474 An information disclosure vulnerability occurs when LibreOffice 6.0.3 and Apache… CVSS 3.0HIGH 7.5
- TI-2019-07230 Code injection in Document Foundation LibreOffice CVSS 3.1CRITICAL 9.8
- TI-2018-05018 LibreOffice before 5.4.5 and 6.x before 6.0.1 allows remote attackers to read arbitrary… CVSS 3.0CRITICAL 9.8
- TI-2023-01118 Arbitrary file write in libreoffice CVSS 3.1MEDIUM 5.5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences