Read the docs
TI-2021-07768 Aliases CVE-2021-25631GHSA-8xj5-7228-hcfg

denylist of executable filename extensions possible to bypass under windows

Priority MEDIUM 46CWE-184Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

In the LibreOffice 7-1 series in versions prior to 7.1.2, and in the 7-0 series in versions prior to 7.0.5, the denylist can be circumvented by manipulating the link so it doesn't match the denylist but results in ShellExecute attempting to launch an executable type.

Why it matters now

EPSS 0.05043 92nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed LibreOffice (The Document Foundation): 7.1.2, 7.0.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
The Document FoundationLibreOffice7.1 to before 7.1.2; 7.0 to before 7.0.57.1.2, 7.0.5Patch availableCNA
  • LibreOffice VendorThe Document Foundation Affected 7.1 to before 7.1.2; 7.0 to before 7.0.5 Fixed in 7.1.2, 7.0.5 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:libreoffice:libreoffice:*:*:*:*:*:*:*:*7.0.0 to before 7.0.5; 7.1.0 to before 7.1.2VulnerableThe Document Foundation
  • cpe:2.3:a:libreoffice:libreoffice:*:*:*:*:*:*:*:* Versions 7.0.0 to before 7.0.5; 7.1.0 to before 7.1.2 Vulnerable ·The Document Foundation

Remediation

  • Fix · CNA LibreOffice (The Document Foundation) Fixed in 7.1.2, 7.0.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-25631
  2. 2026-10-03 Alias added: GHSA-8xj5-7228-hcfg

References

  • TI-2019-07233 LibreLogo global-event script execution CVSS 3.1CRITICAL 9.8
  • TI-2018-12068 Path traversal in [UNKNOWN] libreoffice CVSS 3.0CRITICAL 9.8
  • TI-2018-07474 An information disclosure vulnerability occurs when LibreOffice 6.0.3 and Apache… CVSS 3.0HIGH 7.5
  • TI-2019-07230 Code injection in Document Foundation LibreOffice CVSS 3.1CRITICAL 9.8
  • TI-2018-05018 LibreOffice before 5.4.5 and 6.x before 6.0.1 allows remote attackers to read arbitrary… CVSS 3.0CRITICAL 9.8
  • TI-2023-01118 Arbitrary file write in libreoffice CVSS 3.1MEDIUM 5.5
See all 70 →

Sources