Read the docs
TI-2021-07935 Aliases CVE-2021-25925GHSA-rmp7-f2vp-3rq4

Cross-site scripting in sickrage

Priority MEDIUM 58CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

in SiCKRAGE, versions 4.2.0 to 10.0.11.dev1 are vulnerable to Stored Cross-Site-Scripting (XSS) due to user input not being validated properly when processed by the server. Therefore, an attacker can inject arbitrary JavaScript code inside the application, and possibly steal a user’s sensitive information.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0066 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed sickrage (PyPI): 10.0.11.dev2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—sickrage4.2.0-10.0.11.dev1—No fix listedCNA
—sickrage (PyPI)4.2.0 to before 10.0.11.dev210.0.11.dev2Patch availableGHSA-rmp7-f2vp-3rq4
  • sickrage Vendor— Affected 4.2.0-10.0.11.dev1 Fixed in — No fix listed CNA
  • sickrage (PyPI) Vendor— Affected 4.2.0 to before 10.0.11.dev2 Fixed in 10.0.11.dev2 Patch available GHSA-rmp7-f2vp-3rq4

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:sickrage:sickrage:*:*:*:*:*:*:*:*4.2.0 – 10.0.11VulnerableSickrage
cpe:2.3:a:sickrage:sickrage:10.0.11:-:*:*:*:*:*:*10.0.11VulnerableSickrage
cpe:2.3:a:sickrage:sickrage:10.0.11:dev1:*:*:*:*:*:*10.0.11 dev1VulnerableSickrage
  • cpe:2.3:a:sickrage:sickrage:*:*:*:*:*:*:*:* Versions 4.2.0 – 10.0.11 Vulnerable ·Sickrage
  • cpe:2.3:a:sickrage:sickrage:10.0.11:-:*:*:*:*:*:* Versions 10.0.11 Vulnerable ·Sickrage
  • cpe:2.3:a:sickrage:sickrage:10.0.11:dev1:*:*:*:*:*:* Versions 10.0.11 dev1 Vulnerable ·Sickrage

Remediation

  • Fix · GHSA-rmp7-f2vp-3rq4 sickrage (PyPI) Fixed in 10.0.11.dev2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-25925
  2. 2026-10-03 Alias added: GHSA-rmp7-f2vp-3rq4
  3. 2026-10-08 EPSS moved to the 50th–90th percentile

References

  • TI-2018-06658 SickRage before v2018.03.09-1 includes cleartext credentials in HTTP responses. CVSS 3.0CRITICAL 9.8
  • TI-2021-07936 Cross-site scripting in sickrage CVSS 3.1MEDIUM 6.1

Sources