Read the docs
TI-2021-07965 Aliases CVE-2021-25959GHSA-rwh9-8xx8-4wfm

OpenCRX - Reflected Cross-Site Scripting in Password Reset Functionality

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the password reset functionality. This allows execution of external javascript files on any user of the openCRX instance.

Why it matters now

EPSS 0.00865 58th percentileScored 2026-11-07
Fix Fixed org.opencrx:opencrx-core (Maven): 5.2.0org.opencrx:opencrx-core-models (Maven): 5.2.0+3 more products

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
org.opencrxopencrx-core-config4.0.0 and later—No fix listedCNA
—org.opencrx:opencrx-core (Maven)4.0.0 to before 5.2.05.2.0Patch availableGHSA-rwh9-8xx8-4wfm
—org.opencrx:opencrx-core-models (Maven)4.0.0 to before 5.2.05.2.0Patch availableGHSA-rwh9-8xx8-4wfm
—org.opencrx:opencrx-core-config (Maven)4.0.0 to before 5.2.05.2.0Patch availableGHSA-rwh9-8xx8-4wfm
—org.opencrx:opencrx-client (Maven)4.0.0 to before 5.2.05.2.0Patch availableGHSA-rwh9-8xx8-4wfm
—org.opencrx:opencrx-gradle (Maven)4.0.0 to before 5.2.05.2.0Patch availableGHSA-rwh9-8xx8-4wfm
  • opencrx-core-config Vendororg.opencrx Affected 4.0.0 and later Fixed in — No fix listed CNA
  • org.opencrx:opencrx-core (Maven) Vendor— Affected 4.0.0 to before 5.2.0 Fixed in 5.2.0 Patch available GHSA-rwh9-8xx8-4wfm
  • org.opencrx:opencrx-core-models (Maven) Vendor— Affected 4.0.0 to before 5.2.0 Fixed in 5.2.0 Patch available GHSA-rwh9-8xx8-4wfm
  • org.opencrx:opencrx-core-config (Maven) Vendor— Affected 4.0.0 to before 5.2.0 Fixed in 5.2.0 Patch available GHSA-rwh9-8xx8-4wfm
  • org.opencrx:opencrx-client (Maven) Vendor— Affected 4.0.0 to before 5.2.0 Fixed in 5.2.0 Patch available GHSA-rwh9-8xx8-4wfm
  • org.opencrx:opencrx-gradle (Maven) Vendor— Affected 4.0.0 to before 5.2.0 Fixed in 5.2.0 Patch available GHSA-rwh9-8xx8-4wfm

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:opencrx:opencrx:*:*:*:*:*:*:*:*4.0.0 – 5.1.0VulnerableOpencrx
  • cpe:2.3:a:opencrx:opencrx:*:*:*:*:*:*:*:* Versions 4.0.0 – 5.1.0 Vulnerable ·Opencrx

Remediation

  • Fix · GHSA-rwh9-8xx8-4wfm org.opencrx:opencrx-core (Maven) Fixed in 5.2.0 Advisory →
  • Fix · GHSA-rwh9-8xx8-4wfm org.opencrx:opencrx-core-models (Maven) Fixed in 5.2.0 Advisory →
  • Fix · GHSA-rwh9-8xx8-4wfm org.opencrx:opencrx-core-config (Maven) Fixed in 5.2.0 Advisory →
  • Fix · GHSA-rwh9-8xx8-4wfm org.opencrx:opencrx-client (Maven) Fixed in 5.2.0 Advisory →
  • Fix · GHSA-rwh9-8xx8-4wfm org.opencrx:opencrx-gradle (Maven) Fixed in 5.2.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-25959
  2. 2026-10-03 Alias added: GHSA-rwh9-8xx8-4wfm

References

  • TI-2022-18982 OpenCRX before v5.2.2 was discovered to be vulnerable to password enumeration due to the… CVSS 3.1MEDIUM 5.3
  • TI-2023-21563 OpenCRX version 5.2.0 is vulnerable to HTML injection via the Product Configuration Name Field. CVSS 3.1MEDIUM 6.1
  • TI-2023-21562 OpenCRX version 5.2.0 is vulnerable to HTML injection via Activity Milestone Name Field. CVSS 3.1MEDIUM 6.1
  • TI-2023-21561 OpenCRX version 5.2.0 is vulnerable to HTML injection via the Category Creation Name Field. CVSS 3.1MEDIUM 6.1
  • TI-2023-21560 OpenCRX version 5.2.0 is vulnerable to HTML injection via the Accounts Name Field. CVSS 3.1MEDIUM 6.1
  • TI-2023-21559 OpenCRX version 5.2.0 is vulnerable to HTML injection via Activity Saved Search Creation. CVSS 3.1MEDIUM 6.1
See all 13 →

Sources