CWE-284 Improper Access Control on Configurations Endpoint for the Stable API
Priority LOW 34CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass, Privilege escalation
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284 and CWE-269.
Summary
Improper Access Control on Configurations Endpoint for the Stable API of Apache Airflow allows users with Viewer or User role to get Airflow Configurations including sensitive information even when `[webserver] expose_config` is set to `False` in `airflow.cfg`. This allowed a privilege escalation attack. This issue affects Apache Airflow 2.0.0.
Why it matters now
EPSS 0.02805 86th percentileScored 2026-11-07
Fix Fixed apache-airflow (PyPI): 2.0.1rc1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Airflow | Apache Airflow 2.0.0 | — | No fix listed | CNA |
| — | apache-airflow (PyPI) | 2.0.0 to before 2.0.1rc1 | 2.0.1rc1 | Patch available | GHSA-ffw3-6mp6-jmvj |
- Apache Airflow VendorApache Affected Apache Airflow 2.0.0 Fixed in — No fix listed CNA
- apache-airflow (PyPI) Vendor— Affected 2.0.0 to before 2.0.1rc1 Fixed in 2.0.1rc1 Patch available GHSA-ffw3-6mp6-jmvj
Remediation
- Fix · GHSA-ffw3-6mp6-jmvj apache-airflow (PyPI) Fixed in 2.0.1rc1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-26559
- 2026-10-03 Alias added: GHSA-ffw3-6mp6-jmvj
References
Advisory 4
- https://lists.apache.org/thread.html/r3b3787700279ec361308cbefb7c2cce2acb26891a12ce864e4a13c8d%40%3Cusers.airflow.apache.org%3E
- [oss-security] 20210217 CVE-2021-26559: Apache Airflow 2.0.0: CWE-284 Improper Access Control on Configurations Endpoint for the Stable API
- https://nvd.nist.gov/vuln/detail/CVE-2021-26559
- https://github.com/advisories/GHSA-ffw3-6mp6-jmvj
Other 7
- [announce] 20210217 CVE-2021-26559: Apache Airflow: CWE-284 Privilege Escalation Attack
- https://github.com/apache/airflow/commit/3909232fafd09ac72b49010ecdfd6ea48f06d5cf
- https://github.com/apache/airflow/commit/5e35926c7eda0dfa11a9623e4bf5f60c2bd6b3f6
- https://github.com/apache/airflow
- https://github.com/apache/airflow/blob/486b76438c0679682cf98cb88ed39c4b161cbcc8/CHANGELOG.txt
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2021-2.yaml
- https://lists.apache.org/thread.html/rd142565996d7ee847b9c14b8a9921dcf80bc6bc160e3d9dca6dfc2f8@%3Cannounce.apache.org%3E
More Apache Airflow vulnerabilities
- TI-2020-10905 Missing authentication in Apache Airflow KEVCVSS 3.1CRITICAL 9.8
- TI-2020-09638 OS command injection in Apache Airflow KEVCVSS 3.1HIGH 8.8
- TI-2022-19017 Apache Airflow <2.4.0 has an RCE in a bash example CVSS 3.1HIGH 8.8
- TI-2021-16140 Apache Airflow: Variable Import endpoint missed authentication check CVSS 3.1CRITICAL 9.8
- TI-2022-08169 Apache Airflow: RCE in example DAGs CVSS 3.1HIGH 8.8
- TI-2024-26776 Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler CVSS 3.1HIGH 8.8
Sources
- CVE-2021-26559 · CVE Program
- CVE-2021-26559 · NVD
- FIRST EPSS
- GHSA-ffw3-6mp6-jmvj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences