The merge-deep library before 3.0.3 for Node.js can be tricked into overwriting…
Priority MEDIUM 46CWE-1321Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
The merge-deep library before 3.0.3 for Node.js can be tricked into overwriting properties of Object.prototype or adding new properties to it. These properties are then inherited by every object in the program, thus facilitating prototype-pollution attacks against applications using this library.
Why it matters now
EPSS 0.01917 79th percentileScored 2026-11-07
Fix Partial merge-deep (npm): 3.0.3Red Hat: 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | merge-deep (npm) | before 3.0.3 | 3.0.3 | Patch available | GHSA-r6rj-9ch6-g264 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- merge-deep (npm) Vendor— Affected before 3.0.3 Fixed in 3.0.3 Patch available GHSA-r6rj-9ch6-g264
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:merge-deep_project:merge-deep:*:*:*:*:*:node.js:*:* | before 3.0.3 | Vulnerable | Merge-deep Project |
| cpe:2.3:a:netapp:e-series_performance_analyzer:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
- cpe:2.3:a:merge-deep_project:merge-deep:*:*:*:*:*:node.js:*:* Versions before 3.0.3 Vulnerable ·Merge-deep Project
- cpe:2.3:a:netapp:e-series_performance_analyzer:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
Remediation
- Fix · GHSA-r6rj-9ch6-g264 merge-deep (npm) Fixed in 3.0.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Service Mesh 1 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet: Fix deferred |
Not affected: 2 products
- OpenShift Service Mesh 2.0
- Red Hat OpenShift Container Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2021-26707
- 2026-10-03 Alias added: GHSA-r6rj-9ch6-g264
References
Advisory 5
Sources
- CVE-2021-26707 · CVE Program
- CVE-2021-26707 · NVD
- FIRST EPSS
- GHSA-r6rj-9ch6-g264 · GitHub Advisory Database · CC BY 4.0
- CVE-2021-26707 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences