Improper certificate validation in Puppet Remediate
Priority LOW 34CWE-295Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-295.
Summary
The mechanism which performs certificate validation was discovered to have a flaw that resulted in certificates signed by an internal certificate authority to not be properly validated. This issue only affects clients that are configured to utilize Tenable.sc as the vulnerability data source.
Why it matters now
EPSS 0.00541 45th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Puppet Remediate | Affects Puppet Remediate prior to 2.0, resolved in 2.0 | — | No fix listed | CNA |
- Puppet Remediate Vendor— Affected Affects Puppet Remediate prior to 2.0, resolved in 2.0 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2021-27018
- 2026-10-03 Alias added: GHSA-22qw-g2hg-q8w6
References
Sources
- CVE-2021-27018 · CVE Program
- CVE-2021-27018 · NVD
- FIRST EPSS
- GHSA-22qw-g2hg-q8w6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences