A flaw was discovered in Continuous Delivery for Puppet Enterprise (CD4PE) that results…
Priority LOW 37Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A flaw was discovered in Continuous Delivery for Puppet Enterprise (CD4PE) that results in a user with lower privileges being able to access a Puppet Enterprise API token. This issue is resolved in CD4PE 4.10.0
Why it matters now
EPSS 0.00819 57th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Puppet Continuous Delivery for Puppet Enterprise (CD4PE) | CD4PE prior to 4.10.0 | — | No fix listed | CNA |
- Puppet Continuous Delivery for Puppet Enterprise (CD4PE) Vendor— Affected CD4PE prior to 4.10.0 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2021-27024
- 2026-10-03 Alias added: GHSA-gmmf-cc7v-f9hw
References
More Puppet Continuous Delivery vulnerabilities
- TI-2020-06425 Information disclosure in Continuous Delivery for Puppet Enterprise CVSS 3.1HIGH 7.7
- TI-2019-07983 Sensitive information in log files in Continuous Delivery for Puppet Enterprise CVSS 3.1MEDIUM 6.5
- TI-2020-06426 Insufficiently protected credentials in Continuous Delivery for Puppet Enterprise CVSS 3.1MEDIUM 5.5
Sources
- CVE-2021-27024 · CVE Program
- CVE-2021-27024 · NVD
- FIRST EPSS
- GHSA-gmmf-cc7v-f9hw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences