Read the docs
TI-2021-08738 Aliases CVE-2021-27191GHSA-6q4w-3wp4-q5wf

The get-ip-range package before 4.0.0 for Node.js is vulnerable to denial of service…

Priority LOW 37CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.

Summary

The get-ip-range package before 4.0.0 for Node.js is vulnerable to denial of service (DoS) if the range is untrusted input. An attacker could send a large range (such as 128.0.0.0/1) that causes resource exhaustion.

Why it matters now

EPSS 0.02056 81st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed get-ip-range (npm): 4.0.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—get-ip-range (npm)before 4.0.04.0.0Patch availableGHSA-6q4w-3wp4-q5wf
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • get-ip-range (npm) Vendor— Affected before 4.0.0 Fixed in 4.0.0 Patch available GHSA-6q4w-3wp4-q5wf

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:get-ip-range_project:get-ip-range:*:*:*:*:*:node.js:*:*before 4.0.0VulnerableGet-ip-range Project
  • cpe:2.3:a:get-ip-range_project:get-ip-range:*:*:*:*:*:node.js:*:* Versions before 4.0.0 Vulnerable ·Get-ip-range Project

Remediation

  • Fix · GHSA-6q4w-3wp4-q5wf get-ip-range (npm) Fixed in 4.0.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-27191
  2. 2026-10-03 Alias added: GHSA-6q4w-3wp4-q5wf

References

Sources