Information Disclosure vulnerability in UserAdmin application in SAP NetWeaver…
Priority LOW 23Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Information Disclosure vulnerability in UserAdmin application in SAP NetWeaver Application Server for Java, versions - 7.11,7.20,7.30,7.31,7.40 and 7.50 allows attackers to access restricted information by entering malicious server name.
Why it matters now
EPSS 0.00613 49th percentileScored 2026-11-07
Fix Fixed SAP NetWeaver AS for Java (UserAdmin) (SAP SE): 7.11, 7.20, 7.30 +3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP NetWeaver AS for Java (UserAdmin) | before 7.11; before 7.20; before 7.30; before 7.31; before 7.40; before 7.50 | 7.11, 7.20, 7.30, 7.31, 7.40, 7.50 | Patch available | CNA |
- SAP NetWeaver AS for Java (UserAdmin) VendorSAP Affected before 7.11; before 7.20; before 7.30; before 7.31; before 7.40; before 7.50 Fixed in 7.11, 7.20, 7.30, 7.31, 7.40, 7.50 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:netweaver_application_server_for_java:7.11:*:*:*:*:*:*:* | 7.11 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_for_java:7.20:*:*:*:*:*:*:* | 7.20 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_for_java:7.30:*:*:*:*:*:*:* | 7.30 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_for_java:7.31:*:*:*:*:*:*:* | 7.31 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_for_java:7.40:*:*:*:*:*:*:* | 7.40 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_for_java:7.50:*:*:*:*:*:*:* | 7.50 | Vulnerable | SAP |
- cpe:2.3:a:sap:netweaver_application_server_for_java:7.11:*:*:*:*:*:*:* Versions 7.11 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_for_java:7.20:*:*:*:*:*:*:* Versions 7.20 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_for_java:7.30:*:*:*:*:*:*:* Versions 7.30 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_for_java:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_for_java:7.40:*:*:*:*:*:*:* Versions 7.40 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_for_java:7.50:*:*:*:*:*:*:* Versions 7.50 Vulnerable ·SAP
Remediation
- Fix · CNA SAP NetWeaver AS for Java (UserAdmin) (SAP SE) Fixed in 7.11, 7.20, 7.30, 7.31, 7.40, 7.50
Timeline
- 2026-10-02 Threatist record created from CVE-2021-27621
- 2026-10-03 Alias added: GHSA-2rpq-3585-p54f
References
More SAP Netweaver Application Server For Java vulnerabilities
- TI-2023-00017 Improper access control in SAP NetWeaver AS for Java CVSS 3.1CRITICAL 9.8
- TI-2023-09656 Improper Access Control in SAP NetWeaver AS for Java CVSS 3.1CRITICAL 9.9
- TI-2023-14558 Improper access control during application start-up in SAP AS NetWeaver JAVA. CVSS 3.1CRITICAL 9.1
- TI-2022-10649 Missing authorization in SAP NetWeaver Application Server for Java CVSS 3.1HIGH 7.5
- TI-2021-09087 XML external entity injection in SAP NetWeaver AS for JAVA CVSS 3.1MEDIUM 6.5
- TI-2023-15023 Log Injection vulnerability in SAP NetWeaver AS for Java (Log Viewer) CVSS 3.1MEDIUM 5.3
Sources
- CVE-2021-27621 · CVE Program
- CVE-2021-27621 · NVD
- FIRST EPSS
- GHSA-2rpq-3585-p54f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences