Read the docs
TI-2021-09643 Aliases CVE-2021-28567GHSA-cc3w-r3w8-hfh7

Magento Commerce improper authorization allows an authenticated user to perform certain functions without permission

Priority LOW 30CWE-285Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-285.

Summary

Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are vulnerable to an Improper Authorization vulnerability in the customers module. Successful exploitation could allow a low-privileged user to modify customer data. Access to the admin console is required for successful exploitation.

Why it matters now

EPSS 0.00824 57th percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.4.2-p1, 2.3.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
AdobeMagento Commerceup to 2.4.2; up to 2.3.6-p1; up to 2.4.1-p1; up to None—No fix listedCNA
—magento/community-edition (Packagist)2.4.0 to before 2.4.2-p12.4.2-p1Patch availableGHSA-cc3w-r3w8-hfh7
—magento/community-edition (Packagist)before 2.3.72.3.7Patch availableGHSA-cc3w-r3w8-hfh7
—magento/project-community-edition (Packagist)up to 2.0.2—No fix listedGHSA-cc3w-r3w8-hfh7
  • Magento Commerce VendorAdobe Affected up to 2.4.2; up to 2.3.6-p1; up to 2.4.1-p1; up to None Fixed in — No fix listed CNA
  • magento/community-edition (Packagist) Vendor— Affected 2.4.0 to before 2.4.2-p1 Fixed in 2.4.2-p1 Patch available GHSA-cc3w-r3w8-hfh7
  • magento/community-edition (Packagist) Vendor— Affected before 2.3.7 Fixed in 2.3.7 Patch available GHSA-cc3w-r3w8-hfh7
  • magento/project-community-edition (Packagist) Vendor— Affected up to 2.0.2 Fixed in — No fix listed GHSA-cc3w-r3w8-hfh7

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:*up to 2.4.2VulnerableMagento
cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:*up to 2.4.2VulnerableMagento
  • cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions up to 2.4.2 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions up to 2.4.2 Vulnerable ·Magento

Remediation

  • Fix · GHSA-cc3w-r3w8-hfh7 magento/community-edition (Packagist) Fixed in 2.4.2-p1 Advisory →
  • Fix · GHSA-cc3w-r3w8-hfh7 magento/community-edition (Packagist) Fixed in 2.3.7 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-28567
  2. 2026-10-03 Alias added: GHSA-cc3w-r3w8-hfh7

References

  • TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-35688 ColdFusion | Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') (CWE-22) KEVCVSS 3.1CRITICAL 10.0
  • TI-2025-34084 Adobe Experience Manager | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-19615 Analysis CVE-2023-29300 Bypass: Adobe ColdFusion Pre-Auth RCE KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-13696 Adobe ColdFusion Deserialization of Untrusted Data Arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
See all 8046 →

Sources