The devise_masquerade gem before 1.3 allows certain attacks when a password's salt is…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-269.
Summary
The devise_masquerade gem before 1.3 allows certain attacks when a password's salt is unknown. An application that uses this gem to let administrators masquerade/impersonate users loses one layer of security protection compared to a situation where Devise (without this extension) is used. If the server-side secret_key_base value became publicly known (for instance if it is committed to a public repository by mistake), there are still other protections in place that prevent an attacker from impersonating any user on the site. When masquerading is not used in a plain Devise application, one must know the password salt of the target user if one wants to encrypt and sign a valid session cookie. When devise_masquerade is used, however, an attacker can decide which user the "back" action will go back to without knowing that user's password salt and simply knowing the user ID, by manipulating the session cookie and pretending that a user is already masqueraded by an administrator.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | devise_masquerade (RubyGems) | before 1.3.1 | 1.3.1 | Patch available | GHSA-25f5-gc4h-hc22 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- devise_masquerade (RubyGems) Vendor— Affected before 1.3.1 Fixed in 1.3.1 Patch available GHSA-25f5-gc4h-hc22
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:devise_masquerade_project:devise_masquerade:*:*:*:*:*:ruby:*:* | before 1.3.0 | Vulnerable | Devise Masquerade Project |
- cpe:2.3:a:devise_masquerade_project:devise_masquerade:*:*:*:*:*:ruby:*:* Versions before 1.3.0 Vulnerable ·Devise Masquerade Project
Remediation
- Fix · GHSA-25f5-gc4h-hc22 devise_masquerade (RubyGems) Fixed in 1.3.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-28680
- 2026-10-03 Alias added: GHSA-25f5-gc4h-hc22
References
Advisory 2
Sources
- CVE-2021-28680 · CVE Program
- CVE-2021-28680 · NVD
- FIRST EPSS
- GHSA-25f5-gc4h-hc22 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences